OpenBSD is a security-focused, free and open-source, Unix-like operating system based on the Berkeley Software Distribution (BSD). Theo de Raadt created OpenBSD in 1995 by forking NetBSD. According to de Raadt, OpenBSD is a research operating system for developing security mitigations.
NAME. pf.conf — packet filter configuration file. DESCRIPTION. The pf(4) packet filter modifies, drops, or passes packets according to rules or definitions specified in pf.conf.. This is an overview of the sections in this manual page: PACKET FILTERING including network address translation (NAT). OPTIONS LEMS: Openbsd wiki Firewall Setup. Enable and Reload rules. pfctl -e -f /etc/pf.conf. Reload only. pfctl -f /etc/pf.conf Show Rules and Statistics # pfctl -f /etc/pf.conf Load the pf.conf file # pfctl -nf /etc/pf.conf Parse the file, but don't load it # pfctl -Nf /etc/pf.conf Load only the NAT rules from the file # pfctl -Rf /etc/pf.conf Load only the filter rules from the file # pfctl -sn Show the current NAT 30.3. PF - FreeBSD
PF(4) OpenBSD Programmer's Manual PF(4) NAME pf - packet filter SYNOPSIS pseudo-device pf 1 DESCRIPTION The pf interface is a packet filter pseudo-device for IPv4 and IPv6. pf is administered using the pfctl(8) utility, or through an ioctl inter- face. FILES /dev/pf packet filtering device.
PF(4) OpenBSD Programmer's Manual PF(4) NAME pf - packet filter SYNOPSIS pseudo-device pf 1 DESCRIPTION Packet filtering takes place in the kernel. A pseudo-device, /dev/pf, allows userland processes to control the behavior of the packet filter through an ioctl(2) interface.
Packet Filter (from here on referred to as PF) is OpenBSD's system for filtering TCP/IP traffic and doing Network Address Translation. PF is also capable of normalizing and conditioning TCP/IP traffic, as well PF has been a part of the GENERIC kernel since OpenBSD 3.0. PF was originally developed by Daniel Hartmeier and is now maintained and
OpenBSD PF: Issues with FTP